Skip to main content
Version: 2.4.5

2.4.4 - July 2023

We are excited to announce the release of version 2.4.4 of platform. Here are some of the key updates:

🧩 Components version / Dependencies

  • Olympe DRAW v2.4.4 / Runtime v9.4.4 / Orchestrator v7.1.3

If you are using coded bricks, see the corresponding package.json updates below.

Improvements and other new features

note

This release requires a resetdb of the environment to get the new code as data.

  • BrickContext.waitFor() better handling of errors, in particular EmptyError ("no element in sequence").
  • Add a new properties for Data Sources:
    • restricted use: if activated, only the admin can interact with the data source (eg: transactions and queries). Typically used by backends in remote actions.
  • Use defaultHost parameter to replace required hosts:
    • Eg: In backends, set the "defaultHost" to <environment-name>-frontend.
  • Proper refresh of OAuth2 tokens, even after period of inactivity.
    • Automatic logout if the token has expired when the app wakes up after inactivity.
  • Query results will now be empty if the root instance of a query does not exist.
  • Error message reviewed when code of brick is not loaded properly.
  • Graceful shutdown with timeout: if the graceful shutdown is stuck for any reason, it times out and exit the process anyway after some time (10s by default).
  • Fix getting files content when running a local data source.

Marketplace 2.4.2

  • MSSQL Connector: to be used with a static data model and database schema:
    • Provide the JSON schema in the oConfig of the backend running data sources with the MSSQL connector.
  • Core: new brick Shutdown app: to be used to shut down a service app, typically from a remote action.
  • New Error Flow outputs in Get File Content and Get Binary File Content bricks

CODE update

If you are using coded bricks, please update your package.json file with the following dependencies:

// Dev dependencies:
"@olympeio/dev-tools": "2.4.0",
"@olympeio/draw": "2.4.4",

// Dependencies
"@olympeio/runtime-web": "9.4.4",
"@olympeio/runtime-node": "9.4.4",
"@olympeio/core": "2.4.2"
"@olympeio-extensions/... ": "2.4.2" // <-- version numbers of all extensions are increased